RSS

Firewall Virus

05 Dec

/ip firewall filter
add chain=virus protocol=tcp dst-port=1434 action=drop comment=”port block
warning” disabled=no
add chain=virus protocol=udp dst-port=1434 action=drop comment=”” disabled=no
add chain=virus protocol=udp dst-port=2745 action=drop comment=”” disabled=no
add chain=virus protocol=tcp dst-port=6344-6381 action=drop comment=””
disabled=no
add chain=virus protocol=udp dst-port=6344-6381 action=drop comment=””
disabled=no
add chain=virus protocol=tcp dst-port=1080 action=drop comment=”MyDoom”F
disabled=no
add chain=virus protocol=tcp dst-port=1214 action=drop comment=”” disabled=no
add chain=virus protocol=tcp dst-port=593 action=drop comment=”” disabled=no
add chain=virus protocol=tcp dst-port=1024-1030 action=drop comment=””
disabled=no
add chain=virus protocol=tcp dst-port=135-139 action=drop comment=”Blaster
Worm” disabled=no
add chain=virus protocol=udp dst-port=135-139 action=drop comment=”Messenger
Worm” disabled=no
add chain=virus protocol=tcp dst-port=445 action=drop comment=”Blaster Worm”
disabled=no
add chain=virus protocol=udp dst-port=445 action=drop comment=”Blaster Worm”
disabled=no
add chain=virus protocol=tcp dst-port=1363 action=drop comment=”ndm requester”
disabled=no
add chain=virus protocol=tcp dst-port=1364 action=drop comment=”ndm server”
disabled=no
add chain=virus protocol=tcp dst-port=1368 action=drop comment=”screen cast”
disabled=no
add chain=virus protocol=tcp dst-port=1373 action=drop comment=”hromgrafx”
disabled=no
add chain=virus protocol=tcp dst-port=1377 action=drop comment=”cichlid”
disabled=no
add chain=virus protocol=tcp dst-port=1433-1434 action=drop comment=”Worm”
disabled=no
add chain=virus protocol=tcp dst-port=2745 action=drop comment=”Bagle Virus”
disabled=no
add chain=virus protocol=tcp dst-port=2283 action=drop comment=”Drop Dumaru.Y”
disabled=no
add chain=virus protocol=tcp dst-port=2235 action=drop comment=”Drop Beagle”
disabled=no
add chain=virus protocol=tcp dst-port=2745 action=drop comment=”Drop
Beagle.C-K” disabled=no
add chain=virus protocol=tcp dst-port=3127-3128 action=drop comment=”Drop
MyDoom” disabled=no
add chain=virus protocol=tcp dst-port=3410 action=drop comment=”Drop Backdoor
OptixPro” disabled=no
add chain=virus protocol=tcp dst-port=4444 action=drop comment=”Worm”
disabled=no
add chain=virus protocol=udp dst-port=4444 action=drop comment=”Worm”
disabled=no
add chain=virus protocol=tcp dst-port=5554 action=drop comment=”Drop Sasser”
disabled=no
add chain=virus protocol=tcp dst-port=8866 action=drop comment=”Drop Beagle.B”
disabled=no
add chain=virus protocol=tcp dst-port=9898 action=drop comment=”Drop
Dabber.A-B” disabled=no
add chain=virus protocol=tcp dst-port=10000 action=drop comment=”Drop
Dumaru.Y” disabled=no
add chain=virus protocol=tcp dst-port=10080 action=drop comment=”Drop
MyDoom.B” disabled=no
add chain=virus protocol=tcp dst-port=12345 action=drop comment=”Drop NetBus”
disabled=no
add chain=virus protocol=tcp dst-port=17300 action=drop comment=”Drop Kuang2″
disabled=no
add chain=virus protocol=tcp dst-port=65506 action=drop comment=”Drop PhatBot,
Agobot, Gaobot” disabled=no
add chain=virus protocol=tcp dst-port=27374 action=drop comment=”Drop
SubSeven” disabled=no

# forward
add chain=forward connection-state=invalid action=drop comment=”” disabled=no
add chain=forward connection-state=related action=accept comment=””
disabled=no
add chain=forward connection-state=established action=accept comment=””
disabled=no
add chain=forward action=jump jump-target=Virus comment=”” disabled=no

# input
add chain=input connection-state=invalid action=drop comment=”” disabled=no
add chain=input connection-state=related action=accept comment=”” disabled=no
add chain=input connection-state=established action=accept comment=”” disabled=no
add chain=input action=jump jump-target=virus comment=”” disabled=no

# Tambahan:

/ip firewall filter add chain=virus comment=”Reglas Antivirus”

/ip firewall filter add chain=forward connection-state=invalid action=drop comment=”Drop invalid connections” disabled=no

/ip firewall filter add chain=forward connection-state=established action=accept comment=”Established Connections” disabled=no

/ip firewall filter add chain=forward connection-state=related action=accept comment=”Related connections” disabled=no

/ip firewall filter add chain=forward action=jump jump-target=virus comment=”!!! Check for well-known viruses !!!” disabled=no

/ip firewall filter add chain=forward protocol=udp action=accept comment=”UDP” disabled=no

/ip firewall filter add chain=forward protocol=icmp limit=50/5,2 action=accept comment=”Allow limited Pings” disabled=no

/ip firewall filter add chain=forward protocol=icmp action=drop comment=”Drop excess pings” disabled=no

/ip firewall filter add chain=input connection-state=invalid action=drop comment=”Drop invalid connections” disabled=no

/ip firewall filter add chain=input tcp-flags=!syn connection-state=established action=accept comment=”Accept established connections” disabled=no

/ip firewall filter add chain=input connection-state=related action=accept comment=”Accept related connections” disabled=no

/ip firewall filter add chain=input action=jump jump-target=virus comment=”!!! Check for well-known viruses !!!” disabled=no

/ip firewall filter add chain=input protocol=udp action=accept comment=”UDP” disabled=no

/ip firewall filter add chain=input protocol=icmp limit=50/5,2 action=accept comment=”Allow limited pings” disabled=no

/ip firewall filter add chain=input protocol=icmp action=drop comment=”Drop excess pings” disabled=no

/ip firewall filter add chain=input dst-port=22 protocol=tcp action=accept comment=”SSH for demo purposes” disabled=no

/ip firewall filter add chain=input dst-port=23 protocol=tcp action=accept comment=”Telnet for demo purposes” disabled=no

/ip firewall filter add chain=input dst-port=80 protocol=tcp action=accept comment=”http for demo purposes” disabled=no

/ip firewall filter add chain=input dst-port=3987 protocol=tcp action=accept comment=”winbox for demo purposes” disabled=no

/ip firewall filter add chain=input action=accept log=yes comment=”Log and drop everything else” disabled=no

/ip firewall filter add chain=virus dst-port=135-139 protocol=tcp action=drop comment=”Drop Blaster Worm” disabled=no

/ip firewall filter add chain=virus dst-port=135-139 protocol=udp action=drop comment=”Drop Messenger Worm” disabled=no

/ip firewall filter add chain=virus dst-port=445 protocol=tcp action=drop comment=”Drop Blaster Worm” disabled=no

/ip firewall filter add chain=virus dst-port=445 protocol=udp action=drop comment=”Drop Blaster Worm” disabled=no

/ip firewall filter add chain=virus dst-port=593 protocol=tcp action=drop comment=”________” disabled=no

/ip firewall filter add chain=virus dst-port=1024-1030 protocol=tcp action=drop comment=”________” disabled=no

/ip firewall filter add chain=virus dst-port=1080 protocol=tcp action=drop comment=”Drop MyDoom” disabled=no

/ip firewall filter add chain=virus dst-port=1214 protocol=tcp action=drop comment=”________” disabled=no

/ip firewall filter add chain=virus dst-port=1363 protocol=tcp action=drop comment=”ndm requester” disabled=no

/ip firewall filter add chain=virus dst-port=1364 protocol=tcp action=drop comment=”ndm server” disabled=no

/ip firewall filter add chain=virus dst-port=1368 protocol=tcp action=drop comment=”screen cast” disabled=no

/ip firewall filter add chain=virus dst-port=1373 protocol=tcp action=drop comment=”hromgrafx” disabled=no

/ip firewall filter add chain=virus dst-port=1377 protocol=tcp action=drop comment=”cichlid” disabled=no

/ip firewall filter add chain=virus dst-port=1433-1434 protocol=tcp action=drop comment=”Worm” disabled=no

/ip firewall filter add chain=virus dst-port=2745 protocol=tcp action=drop comment=”Bagle Virus” disabled=no

/ip firewall filter add chain=virus dst-port=2283 protocol=tcp action=drop comment=”Drop Dumaru.Y” disabled=no

/ip firewall filter add chain=virus dst-port=2535 protocol=tcp action=drop comment=”Drop Beagle” disabled=no

/ip firewall filter add chain=virus dst-port=2745 protocol=tcp action=drop comment=”Drop Beagle.C-K” disabled=no

/ip firewall filter add chain=virus dst-port=3127-3128 protocol=tcp action=drop comment=”Drop MyDoom” disabled=no

/ip firewall filter add chain=virus dst-port=3410 protocol=tcp action=drop comment=”Drop Backdoor OptixPro” disabled=no

/ip firewall filter add chain=virus dst-port=4444 protocol=tcp action=drop comment=”Worm” disabled=no

/ip firewall filter add chain=virus dst-port=4444 protocol=udp action=drop comment=”Worm” disabled=no

/ip firewall filter add chain=virus dst-port=5554 protocol=tcp action=drop comment=”Drop Sasser” disabled=no

/ip firewall filter add chain=virus dst-port=8866 protocol=tcp action=drop comment=”Drop Beagle.B” disabled=no

/ip firewall filter add chain=virus dst-port=9898 protocol=tcp action=drop comment=”Drop Dabber.A-B” disabled=no

/ip firewall filter add chain=virus dst-port=10000 protocol=tcp action=drop comment=”Drop Dumaru.Y” disabled=no

/ip firewall filter add chain=virus dst-port=10080 protocol=tcp action=drop comment=”Drop MyDoom.B” disabled=no

/ip firewall filter add chain=virus dst-port=12345 protocol=tcp action=drop comment=”Drop NetBus” disabled=no

/ip firewall filter add chain=virus dst-port=17300 protocol=tcp action=drop comment=”Drop Kuang2″ disabled=no

/ip firewall filter add chain=virus dst-port=27374 protocol=tcp action=drop comment=”Drop SubSeven” disabled=no

/ip firewall filter add chain=virus dst-port=65506 protocol=tcp action=drop comment=”Drop PhatBot, Agobot, Gaobot” disabled=no

 
Leave a comment

Posted by on December 5, 2008 in Uncategorized

 

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: