RSS

Membatasi Download di Mikrotik

15 May

Kadang seorang administrator jaringan akan mengalami “pusing” atas ulah para client yang mggunakan download accelator seperti Free Download Manager (FDM), Internet Download Manager (IDM) dan download accelerator yang lain. Hal ini menyebabkan alokasi bandwith yang ada di sedot sendiri… sementara yang lain mau browsing saja susah ..lama… huuuuhhhhhh…  Nah.. untuk mengakali nya ada cara yang efektif membatasi bandwitdh download tanpa mengganggu browsing secara keseluruhan.

Sebenarnya tutorial ini sudah ada di paman Google juga.. Namun tidak ada salah nya penulis mencoba memodifikasi dengan cara yang sedikit berbeda tapi intinya sama.  OK.. langsung saja ikuti langkah-langkah berikut……

sebelum berlanjut, ada beberapa tahapan yang perlu kita perhatikan antara lain, kapasitas bandwith yang kita miliki, firewall, mangle, dan simple queu

Langkah pertama kita mensetting firewall. berikut ini script nya :

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.exe action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.iso action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.mpg action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.zip action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.rar action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.dat action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.flv action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.3gp action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.mpeg action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.avi action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.ram action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.mov action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.wma action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.aiff action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.au action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.wav action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.rar action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

Keterangan :

ip address yang ada di script adalah ip network, oleh karena itu sesuaikan dulu dengan ip network anda, tcp content merupakan EXTENSI file yang sering di download oleh client, jika anda merasa kurang, silakan di tambahi sendiri. Address list cekek nantinya akan muncul otomatis di menu ip firewall  address list dengan nana cekek (di cekik, red) . Blok smua Script di atas kemudian anda paste kan di menu New terminal, akhiri dengan enter.

Langkah berikutnya adalah menginisialisai marking packet di mangle dengan script di bawah ini :

/ip firewall mangle add chain=forward protocol=tcp src-address-list=cekek action=mark-packet new-packet-mark=cekek-bw-by-extension

maksudnya, semua traffict tcp yang di kenali pada extension file yang di download akan di mark (ditandai) sebagai cekek-bw-by-extension yang selanjutny akan di kenali di firewall address list sehingga alamat ip yang di download akan terdeteksi otomatis.

Langkah terakhir, adalah  memasukkan marking packet yang kita buat di mangle agar di kenali oleh queu dengan memasukkan script dibawah ini

/queue simple add-files max-limit=32000/64000 packet-marks=cekek-bw-by-extension

artinya kita membatasi download extension file 32kbps upload dan 64kbps dowload.  jika bandwitdh anda CEKAK  perlu di CEKEK  mereka-mereka yang suka ngedownload. Bagi anda yang memiliki bandwitdh besar silakan sesuaikan kapasitas downlod yang ingin anda berikan.. bisa 128kbps, 256kbps 512kbps up to you dah….

OK selesai..

Berikut ini penulis sertakan capture hasil settingan di atas..

1. Firewall Filter

2. Mangle

3.  simple queues

4. Address list

Mudah-mudahan bermanfaat….

Selamat mengoprek..

 
27 Comments

Posted by on May 15, 2010 in Tutorial Mikrotik

 

27 responses to “Membatasi Download di Mikrotik

  1. Papa Cholie

    August 16, 2011 at 1:37 pm

    sudah saya coba mas… ternyata harus passthrough=no supaya packet mark gak dilangkahi IDM hehehe makasih mas udah share🙂 tested dan download bener2 di cekek…

     
    • tamam_papua

      August 21, 2011 at 4:35 pm

      ok selamat menCEKEK… wakakakakakaka

       
  2. Bandi Shippuden

    November 28, 2011 at 5:33 pm

    mas kalo ngelimit youtube bagai mana ?
    saya udah coba ngelimit dengan extensi file tapi gak mau juga ….
    mohon penserahanya mas ….

     
    • tamam_papua

      November 29, 2011 at 5:45 pm

      gunakan settingan layer7 untuk kasus anda….

       
  3. lyeban

    November 29, 2011 at 5:50 pm

    saya menggunakan mikrotik pc v. 2.9.6 ….
    jadi gak ada layer 7nya ….
    mohon bantuannya mas …

     
    • tamam_papua

      December 1, 2011 at 10:15 am

      owh.. ya anda tinggal tambahkan extension file yang dipake youtube atau streaming adalah, biasanya .flv .wmv .video .videos dan lain lain anda visa liat di settingan layer7 untuk extension file nya

       
  4. Bandi Shippuden

    December 1, 2011 at 8:15 pm

    mas saya udah coba setting limit youtube … dan hailnya memuaskan …
    tapi saya mendapati masalah lagi ne mas … settingan bloking situs jadi gak jalan …
    bagai mana mas solusinya …. ?

     
  5. Hariyanto Adjie Nugroho

    December 18, 2011 at 4:25 pm

    mas klo misalnya mau mangle di mikrotik itu kita pakai forward atau prerouting.
    trus bedanya dimana ketika kita menggunakan forward / prerouting.thanks

     
    • tamam_papua

      December 19, 2011 at 10:14 am

      intinya prerouting = input sebelum traffict masuk ke mikrotik, forward= traffict yang masuk di forward/diarahkan kemana, postrouting= akhir dari traffict di tujukan kemana. Banyak penjelasan di internet, tidak ada salahnya anda googling. Dan saya yakin sebetulnya anda sudah tahu cmiwwww

       

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: